PHP is one of the most commonly used coding languages. It is very popular as it is free software, which you can use to build interactive websites such as community sites, e-shops or online teaching portals rather than static HTML sites. A PHP module must be present on the web server where a PHP-driven site is hosted so that its source code can be ‘translated’. Since there are no license charges for this sort of module and the language itself offers endless options for the web apps that you create, there are 100s of millions of PHP-driven sites. Also, there are a myriad of open-source PHP scripts, which you can use for your sites without having to possess any coding know-how. Since there are a few versions of PHP, you should confirm whether the same exact version that you used while setting up your site is present on the web server as well.

PHP 4 and PHP 5 Support in Cloud Hosting

With our cloud hosting, you will be able to select which PHP version will be enabled for your shared account, since we support different versions. With only one click, you’ll be able to switch between PHP 4, 5.2, 5.3, 5.4 and 5.5 and every time a new version is released in the future, we will add it to the Hepsia Control Panel without removing the older ones. Thus, you will be able to host all the websites that you have built through the years. In contrast to many other hosting vendors, we won’t force you to update such sites, because a script may be outdated, but this does not automatically mean that it’s vulnerable as you may have tweaked its source code to fix security holes. For your convenience’s sake, you will even be able to select a different PHP version for each single website hosted in your shared hosting account.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

If you’ve got a website built using a previous version of PHP and you’ve devoted time and efforts into setting it up, repairing safety breaches and adding web content, you will need to find a hosting service that can support it, as the vast majority of hosting suppliers nowadays offer support only for the newest PHP version and drop the previous versions. We, on the other hand, have decided to allow you to choose the exact version that your very own sites require. Our semi-dedicated hosting plans support multiple versions of PHP 5 and PHP 4, which implies that you will be able to use both newer and older scripts without losing any manual settings or frittering away time attempting to make your websites compatible with the web hosting environment. The current version can be changed from the Hepsia hosting Control Panel and such an update will apply to the whole semi-dedicated server account, but you will also be able to specify a different version of PHP for each single site that you host in your account by using an .htaccess file.